SAP Knowledge Base Article - Public

2357652 - Learning Expiration Notification not received even when APM settings are correct - LMS

Symptom

Learning Expiration Notification APM is scheduled to run and executes without any issues, However, No Expiration/Overdue emails received.

Environment

SuccessFactors Learning Management System

Reproducing the Issue

->Have a course assigned to a user with a due date .

->Schedule the Learning Expiration APM to run with particular Threshold and Reminder values such that the Expiration/Overdue email needs to be triggered.

->The Learning Expiration (Or Overdue email in case the due date is in past) is not triggered to the user, even when the APM level settings are correct.

Cause

The Cause for this is that  the settings for the Expiration Emails at the Item level(Under Related -> more ->Notifications -> Override Learning Expiration Notification Defaults is not present.

This happens mainly when, the Learning Expiration APM is scheduled after the Items have already been created in the system.

The Item level settings, override the APM level settings and hence the Expiration emails are not being sent to the users.

Had, the Items been created in the system after the APM was scheduled, it would inherit the settings for the Threshold and Reminder from the APM and triggered emails accordingly.

The screen shot of these settings is below:

2.PNG

 

Resolution

The resolution for this would be to add the settings at the Item level manually .

Another option would be to make sure that the APM is scheudled first and the items be craeted in the system afer the APM is scheduled so that the items can inherit the settings of the APM.

 

Keywords

Expiration Email not sent, LearningExpiration Notification expiry , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions