2354890 - Incorrect/No data for an EC field in report although data is available in Employee central

SAP Knowledge Base Article - Public

2354890 - Incorrect/No data for an EC field in report although data is available in Employee central

Symptom

  • Report is not showing the value of a field from Employee Central.
  • Report is showing incorrect value of a field from Employee Central.
  • No data in report for a field although data is available in Employee Central.

 

Environment

SAP Successfactors

Advanced Reporting

Adhoc Reports

Reproducing the Issue

  1. Create a report in Advanced Reporting or from any EC domain available in Adhoc framework.
  2. Incorrect or No data in one of the field although data is available in EC.

Cause

There can be multiple reason of this and one of them could be the Event Type of the rule calculating the value of that field.

  1. Go to Admin Center -> Manage Business Configuration
  2. Select the Portlet where the field is present.
  3. Scroll down to the page end and go to Trigger Rules section.
  4. See the Event Type of the rule selected to display the data of the field on the portlet.
  5. If the Event Type is selected as "On View", then the calculated value do not get store on Database as it is calculated on the fly and displayed on the portlet. 
  6. Calculated value will not be shown in report as it is not saved in Database.

1.PNG

 

Resolution

In order to resolve the issue and reflect the calculated value in Report you need to change the Event Type from "On View" to something else.

Keywords

No data in Report Advanced Reporting Employee Central Adhoc Report On View Business Rule , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem

Product

SAP SuccessFactors Workforce Analytics all versions