2351060 - Error while importing SCORM Course - "The SCORM parser could not recognize the package schema version. Please select a SCORM package version and import the SCORM file."

SAP Knowledge Base Article - Public

2351060 - Error while importing SCORM Course - "The SCORM parser could not recognize the package schema version. Please select a SCORM package version and import the SCORM file."

Symptom

  • The error below is dislayed while importing SCORM course via Import Content Tool.

1.jpg

Environment

  • Learning Management System

Cause

  • There are 2 possible causes for this issue
  1. Schema Version is missing in the SCORM Course IMSManifest file.
  2. Schema Version is incorrectly formatted in the SCORM Course IMSManifest file.

Resolution

  • To fix the issue, the content developer needs to correct the Schema Version in the IMSManifest file to match the SuccessFactors LMS pattern.
  • Below is an example of SCORM 1.2 Schema Version.

-<metadata>

<schema>ADL SCORM</schema>

<schemaversion>1.2</schemaversion>

</metadata>

See Also

  • You can find more information regarding SCORM versions 1.2, 2004 2nd and 4th Editions and also for AICC by clicking here.
  • Please find in the Attachment section a sample IMSManifest file which can be downloaded and used for comparison

 

Keywords

  • SCORM, 1.2, 2004, 2nd, 4th, IMSManifest, Schema Version, import content tool, import, content, error, The SCORM parser could not recognize the package schema version. Please select a SCORM package version and import the SCORM file.
, KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , SuccessFactors Learning , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

imsmanifest.xml