2349817 - Candidates being auto-disqualified incorrectly

SAP Knowledge Base Article - Public

2349817 - Candidates being auto-disqualified incorrectly

Symptom

Candidates are being put in autodisqualifed status even after answering the pre screen questions correctly  

Environment

Recruiting Management

Reproducing the Issue

  1. Create profile in an instance that has mobile apply enabled 
  2. Save an application and then apply later from the saved application link or apply, or update application from jobs applied link or apply to a job in a language other than en_US 
  3. Application is sent to auto disqualify status

Cause

This was a defect that was occurring when Mobile apply feature was enabled in customer instance  and was occurring in the following cases:

1. New line char appended to answer while saving or updating job application Save job application as draft and again open that application from saved application link and try to apply it now – 1st scenario to reproduce

2. Try apply without saving as draft and again open that application from job applied link and try to update it now -   2nd scenario to reproduce

3. Job requisition posted to multi languages example en_UK, en_US and de_GE and you are applying to that job req using other than en_US language, Candidate moved to disqualified status. ( Root cause : en_US hardcoded in backend file and its creating problem if suppose questions configured in multiple languages)

 

Resolution

  1. This is a 1608 Release fix on RCM-32524  and has been patched on PTCH-24051
  2. Create a candidate profile in an instance with mobile apply enabled
  3. Save a application and apply from the saved application link or submit application and then update it from jobs applied link or submit application for a job posting in language other than en_US
  4. Application is not set to autodisqualify in error

Keywords

KBA , LOD-SF-REC , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting 1605