SAP Knowledge Base Article - Public

2325359 - Certain users encounter an application error message while accessing Analytics

Symptom

  • This article explains the cause and resolution for a scenario where certain users (roles) face an Application error message when they access the Analytics / ORD sub-tab.

 

Environment

  • Online Report Designer (ORD)
  • BizX-ORD Single Sign On

Reproducing the Issue

  • Login into the instance as one of the affected users.
  • Navigate to
    Home > Analytics > Analytics
  • They encounter the following error message while the other users are able to access Analytics as usual.

    Application_Error.png

Cause

  • The user's role in ORD (not in BizX) has been assigned a starting page to which the user / role doesn not have access to.

 

Resolution

  1. Login to the instance as a user who has 'User Maintenance' and 'Role Maintenance' access in Analytics
  2. Navigate to Analytics
  3. Access Report Designer
  4. Create a New Report and add a blank page to it. We don't have to add any component to it now.
  5. Navigate to the Analytics Admin Page.
  6. Click 'User Maintenance'
    User_maintenance.png

  7. Search for the affected user and make a note of their Role.

    User_Search.png

  8. Navigate to the ORD Admin Page and click 'Roles Maintenance'
  9. Search for and select the role identified in the above step 4.
  10. Edit the role and change the start page to one the user has /has been granted access to.
    Change_Start_Page.png
  11. The affected user(s) should now be able to access Analytics
  12. If they are still facing issues, repeat steps 6 to 9 and make the blank report page (created in step 4) as the starting page.
  13. If step 11 resolves the issue, it implies that some part of the current configuration restricts the user from access the page or the components of the page assigned earlier.

 

Keywords

KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM Core all versions