SAP Knowledge Base Article - Public

2316953 - Troubleshooting when Course / Content is not being marked as completed in LMS

Symptom

  • Users completed the course but it is still in their learning plan
  • The course displays a certificate informing the users that they have completed the course but the same is not reflecting in the user's learning history/plan
  • The course is not being marked "Completed" even though it was completed successfully

Environment

  • LMS with iContent
  • SAP SuccessFactors Learning Management System

Reproducing the Issue

  1. Complete an iContent course in LMS
  2. The course continues to display in Learning Plan
  3. The course is not marked as completed as expected

Cause

This can be caused by the following (see resolutions/troubleshooting steps below for each cause):

  1. The content is not sending the completion statues properly
  2. The settings are incorrect at the Item Level
  3. Users are not meeting the "completion" requirements as configured
  4. In an integrated environment, the session maintenance settings are incorrect

Resolution

When an item is not marking the item/course completed is because of the following reasons:

  1. The content is not sending the completion statues properly
    • For example, the content object should send the status as "Passed"(P) or "Completed"(C) which depends on the type of contents, such as AICC or SCORM (click here for more details)
    • If it sends some other improper text as the status, LMS will not recognize it and will not mark it complete
    • If this is the case, all users will have issues with the course
    • Be sure the content is configured to send the expected completion status to the LMS for the correct status to be set
  2. The settings are incorrect at the Item Level
    • If this is the case, all users will have issues with the course
    • Search and open an item at Admin->Learning->Items->Search and open/click on an item->"Online Content"
    • Under Related tab -> Settings-> Modify Settings make sure that "Record Learning event when all content/quiz/exam is complete" is checked and has a "Completion Status" selected from the dropbox below that setting:
      • Item-Content.jpg
    • And at the content object level, the setting, "Record learning event when content/quiz/exam passed" is checked if needed
      • Item-AllContent.jpg
    • If both settings are not made, enable them and reassign the item/course to the affected users to correct the issue
  3. Users are not meeting the "completion" requirements as configured. For example: 
    • There are content objects that send the status only when the user clicks a button, such as "Exit" or "Close" or "X" or "Submit" etc., on the last slide/page
    • Some content sends the status when the content/browser window is closed
    • Some content sends the status the moment it is launched (when the item is set to "Mark this object complete when launched")
    • If this is the case, users who do not complete the courses properly will not receive credit for it
    • To correct, observe the steps the user is taking to complete the course and determine which steps may be missed to meet the course's configured requirements for completion
  4. In an integrated environment, the session maintenance settings are incorrect
    1. Under LMS->Admin->System Admin->Configuration->System Configuration->LMS_ADMIN:
      • "contentStructurePageExpireDuration" and "contentStructurePageKeepAliveInterval" have to be 120 (recommended value)
      • Please change it to 120 if not (lesser the better, as the content page could ping the server more frequently to maintain the session)
    2. Under LMS->Admin->System Admin->Configuration->System Configuration->AUTHENTICATION:
      • httpSessionTimeout should be 1700 (approximately 30 minutes)


Additional Information:

  • If all points above have been checked and the issue persists, check the user's browser settings to be sure they meet the recommendations for LMS, clear browser cache and test again
  • If the issue persists, please go through this link for assistance to continue troubleshooting the issue.

See Also

2473031 - Item does not move to Learning History after user completion

2456141 - SCORM Content completion status are not getting accepted by LMS causing completion issues in LMS

2310570 - Internet Explorer settings to launch online content - LMS

2251443 - Score is not Captured in Learning History

2465583 - Completion Status not populated in PA_CBT_STUD_CPNT causes completion inconsistency

Keywords

LMS SF SuccessFactors Success Factors Learning Management System mark marked complete pass passed online object item content not working, course incomplete, content issues, not marking completed, user completed it but, still in the learning plan , KBA , LOD-SF-LMS-CNT , Content , Problem

Product

SAP SuccessFactors Learning all versions