SAP Knowledge Base Article - Public

2316286 - Data discrepancy in the ORD reports generated with "Schedule Offering Registration" and "Item Cost and Order information" - [LMS]

Symptom

ORD tool is providing all the desired Item related records when it is pulled from "Schedule Offering Registration" but not all the records when we pull the same data from "Item Cost and Order information".

 

1) Learning->Item Cost and Order information-> required fields as mentioned below:-

    Learning->Item Cost and Order information->Item-> ID, Title

    Learning->Item Cost and Order information->Schedule Offering-> ID, Active, Start date, End date, Closed Date

Item Cost and Order Informtion.jpg

Analysis : If this method is used, the system is not showing all the SOs that it should but only a few.

 

2) Learning->Schedule Offering Registration->required fields as mentioned below:-

    Learning->Schedule Offering Registration-> Item-> ID, Title

    Learning->Schedule Offering Registration-> Schedule Offering->ID, Active, Start date, End date, Closed Date

Schedule Offering Registration.jpg

Analysis : If this method is used, the system is showing all the SOs that it should.

Environment

SAP SuccessFactors Workforce Analytics

SuccessFactors Learning Management System (LMS) - All Supported Versions since 1508

Resolution

The reason why the system does not fetch the data for few Items is because the default period for mandatory filter prompts for which the ORD (adhoc) reports shall be generated with is 36 months and if a SO with an Item ID is created before 36 months from when you are running the report, since the period is more than 36 months here they would not included in the resulting report.

For Item Cost and Order Information Report : the base parameter is "Item Creation Date":
--------------------------------------------------------------------------------------------------------------------------
When we select/run a report in the ORD, it would ask for the start and end date and if we do not specify any values, the default period of 36 months(3 years) would be taken and the report would be generated only for Items created within 36 months and if there are any data prior to that setting, the system would be not get the data.
--------------------------------------------------------------------------------------------------------------------------

The reason why ORD was able to pull the data for "Schedule Offering Registration Report" is because, the base parameter is "Registration Date" and the Registration date in case of all the SOs might be well within 36 months.

To change the default setting, please go to the LMS admin side and navigate to System Admin > REPORT_SYSTEM > search for adhocReportDefaultPeriod

Default is set to 36 months. Please increase the default value that you deem appropriate. Try it in ORD again and the issue should be fixed.

Note > adhocReportPreviewModeDefaultPeriod is the time period for Preview mode of reports the default for which is 3 months.

Keywords

Data discrepancy in the ORD reports, Schedule Offering Registration, Item Cost and Order information, item, scheduled offering, cost and order, adhocReportPreviewModeDefaultPeriod, adhocReportDefaultPeriod , KBA , LOD-SF-LMS-ORD , Online Report Designer , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , Problem

Product

SAP SuccessFactors Learning all versions ; SAP SuccessFactors Workforce Analytics all versions