SAP Knowledge Base Article - Public

2292809 - Jobs are not posting using Real Time Job Sync - Recruiting Marketing

Symptom

External jobs are posted in Recruiting Management (RCM) but are not appearing in Recruiting Marketing (RMK).

Environment

  • SAP SuccessFactors Recruiting Marketing 
  • Recruiting Management and Recruiting Marketing integration with Real Time Job Sync (RTS)

Cause

A possible cause is the job could be that the job is not posted on RCM yet. Jobs posted externally in RCM (“Corporate Posting” on the Job Postings page) are sent to RMK in near-real time. Usually this process happens in under a minute, but depending on the time of day, it can take up to 20 minutes for a job to post in RCM.

Resolution

1. Recruiting Marketing Job Field Mapping

Ensure that the mapping between the Recruiting Management and Recruiting Marketing fields is not incomplete or wrong.

Please refer to the following Knowledge Base Article for further details: 2557601

2. "Sync all External Job Postings" Scheduled job on Provisioning - PARTNERS ONLY

Ensure that the scheduled job "Sync all External Job Postings" is set up properly by following the instructions below:

  1. Make sure the job has the a valid Job Owner.
  2. Make sure the job runs daily and only once per day. A fullfeed that runs more than once per day can cause many problems on the integration between RCM and RMK.
  3. Make sure the job runs on a period of low activity on the system. The recommendation is set the job to run at night.

If your mapping is completed and the job  "Sync all external job postings" are following the information provided on this article, please submit a support incident with us and we will investigate the internal configuration.

Keywords

Real Time Job Sync, Jobs not posting, RTJS,Recruiting Marketing Mapping Fields, Sync all external job postings,RMK Scheduled Job , KBA , LOD-SF-RMK , Recruiting Marketing , Problem

Product

SAP SuccessFactors Recruiting all versions