SAP Knowledge Base Article - Public

2278874 - Seamless Login Issue and Fix - Onboarding

Symptom

  • Seamless login issue while accessing  onboarding instance

Environment

  • Applicable for all DC centres and KMS(Zerolag) Customers
  • Onboarding
  • Provisioning

Cause

  • User Sync Failure.
  • Wrong configuration of Authorized SP Assertion Consumer Service Settings.
  • SF_UserDefinedFields.xml may be corrupted
  • User has defined two the same locales in SuperAdmin

Locales.png

Resolution

1. Check whether user sync has been properly happened and users are synced to onboarding.

2. Bizx Side : In Provisioning, under "Authorized SP Assertion Consumer Service Settings", for "Assertion Consumer Service" and "Audience URL" fields, the KMS environment URL appended with the Path and the extension "/SSO/SAML20/AssertionConsumerService.aspx" should be given.

eg: if the instance is in DC8, and the account is in ONBPREM, then the url should be :
https://onboarding8.successfactors.com/ONBPREM/SSO/SAML20/AssertionConsumerService.aspx

KMS side : The same URL specified in Bizx should be given in KMS Administration site, under Account Options, for the key Security.SAML20.audience.

3. SF_UserDefinedFields.xml may be corrupted - this is caused by a script error

When the file gets corrupted, a temp file is created and this file needs to be replaced with the corrupted file.

PLEASE CREATE an Incident in the SAP Support Portal for further investigation and resolution

4. Please delete the extra locale and the issue is resolved.

Keywords

  • Seamless Login Error.
, KBA , LOD-SF-OBD-ONB , Onboarding Core , Problem

Product

SAP SuccessFactors Onboarding all versions