SAP Knowledge Base Article - Public

2278836 - Permission Sync Issue and Fix

Symptom

  • Permission Sync is not working, user's permissions are not syncing from BizX to ONB
  • File is not generated and placed in SFTP
  • File in the SFTP is not picked up by Onboarding
  • Few of the column information is synced and few column information is not synced.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding

Cause

  • Sync Between BizX and SFTP Fails(i.e.File is not generated and placed in SFTP)
  • Sync between SFTP and ONB Module(i.e. File is placed in SFTP but it not picked up from SFTP)
  • Sync between SFTP and ONB Module(i.e. File is picked up from SFTP but few column information is not synced to Onboarding)

Resolution

Scenario 1

Permission sync file not getting sent to SFTP

  1. Image of Job in SFTP
    SFTP.png
  2. Provisioning
  3. Manage Schedule Jobs
  4. Filter by Ad Hoc
  5. Check that the job is present
  6. Check if job is submitted
  7. If the job is not submitted this action is the reason why the file is not placed in SFTP
    Job Submitted in Provisioning.png
  8. If submitted, and not placed in SFTP
  9. Click the job name to open it
    Send File to SFTP.png
  10. Check that the “File available in FTP?” option is checked because that is the option that sends the file to SFTP once it has been submitted.
  11. A correctly configured job in provisioning looks like below.
    Correctly configured job in Provisioning.png

Scenario 2

File is going to SFTP, but it’s not being picked by onboarding.

  1. Provisioning
  2. Company setting
  3. Check for Onboarding Account ID
    Account Name.png
  4. Super Admin, find account, Features, Foundation Import.
    Foundation Import Feature.png
  5. If the foundation import feature is enabled, ensure that the SFTP folder is correct for example, /ONB/inbound, and the host address.
  6. Go back to Provisioning, Manage Schedule jobs, filter by Ad Hoc reports and click the job
  7. Logon to SFTP using the below credentials that will be displayed on the job
    Logon to SFTP.png
  8. Check the folder based on the path to see if the file is Available
    File Path.png
  9. Find your job in the ONB inbound folder.
  10. Check that the file name on the job in provisioning is correct
    File Name.png
  11. The file name consists of ONBaccountID_Permission_Sync.csv
  12. If the above are completed and the file is still not getting picked up.
  13. Open the report in SFTP check the row headings on the report
  14. Navigate to Super Admin
  15. Import Export Settings
  16. FoundationImportFieldMapping
  17. Export the files, and check that the name of the columns in the XSLT file matches the name of the row headings on the report
    Import File.png
    Foundation Import XSLT.png
  18. The username is not important, User ID and Role Name is required.
  19. Job Owner below
    Job Owner.png

Scenario 3

The permission sync is working, but users are not going to the designated groups in Onboarding

  1. Navigate to provisioning
  2. Manage schedule Jobs
  3. Select Job Type by Ad Hoc
    Find Job.png
  4. Click Refresh on the right
  5. Click the permission sync Job
  6. Logon to SFTP using server access credentials
    Logon to SFTP.png

  7. Run the job by hovering over “Select” on the right
    Run Sync.png
  8. Click “Run it now”
  9. Click “Monitor Jobs”
    Monitor Job.png
  10. Check the status of the job to see is it completed
    Completed Job.png
  11. Once completed navigate to SFTP
  12. Click folder name ONB
  13. Click Inbound
  14. Double-click the permission sync file to open it
  15. In the Excel file, click Data
  16. Filter
  17. Search for the user by the user ID
    Search for User.png

  18. If the user is not there that is the reason the permission is not syncing over,
    you must tell the client to add the user in the respected permission groups in BizX
  19. If the user is there check what permission roles are associated with the user
    Roles in Report 1.png
  20. Now navigate to Onboarding
  21. Security
  22. Groups
  23. Check that the role name in the report matched the group name is Onboarding
    Roles in Report Vs Groups In Onboarding.png
  24. After the above steps are completed if the job is sent to Onboarding, but failing
  25. Navigate to Onboarding
  26. Settings
  27. Audit Trail
  28. Select a blank value from the “Type”
  29. Enter INT for “Event code”
  30. You can select an “Event From” or take the default date if the sync failed today
  31. Double-click the job copy the error and open an incident with Support

Tips and Common Error

  1. Do not add the Onboarding account name in the Foundation Import file on FileMask row.
  2. Ensure to leave the default as shown below
    FileMask.PNG

                                                          Keywords

                                                          Permission Sync, SFTP, Recruiter, Hiring Manager, Provisioning, Super Admin, Job, Foundation Import , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , How To

                                                          Product

                                                          SAP SuccessFactors Onboarding all versions