2276228 - SAML2 Error Occurs When Accessing Appointments From Feeds

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2276228 - SAML2 Error Occurs When Accessing Appointments From Feeds

Symptom

SAML2 error occurs when accessing Appointments from Feeds.

Reproducing the Issue

  1. Go to the Activities work center.
  2. Go to Appointments View.
  3. Select All on filter.
  4. Search for appointment XYZ (XYZ represents the ID of the appointment).
  5. Create a new comment on appointment XYZ.
  6. Try to open the appointment in Feed work center.
  7. Error appears: SAML2-Service not reachable.

Cause

The user has logged in with SSO however the link opens is Non-SSO which is causing SAML 2.0 error.

Resolution

Ensure below pre-requisites are fullfilled:

  • Within scoping under JAM integration - you should select the option to use SSO URL.
  • Once done then all feed links for appointment will have SSO URL.
  • The user should have logged in via SSO to the C4C system and when user clicks the appointment link, it will directly open the object without any prompt for login.

Steps to do do scoping changes:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the project and choose Edit Project Scope.
  4. Go to the step 4 Questions.
  5. Expand Communication and Information Exchange.
  6. Expand People Collaboration, Intranet and External Services.
  7. Select Communities, Document Management and External Services.
  8. Scope the question Do you want to use C4C SSO URL for Jam Integration?
  9. Review and Finish the changes.

 

Keywords

KBA , AP-CI , Customer Invoice Processing , How To

Product

SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Hybris Cloud for Customer 1605 ; SAP Hybris Cloud for Customer 1608 ; SAP Hybris Cloud for Customer 1611 ; SAP Hybris Cloud for Customer 1708 ; SAP Hybris Cloud for Customer 1711 ; SAP LE APPL.PLATFORM 1708