SAP Knowledge Base Article - Public

2271773 - Logged out when trying to Proxy

Symptom

  • Each time we try to use Proxy functionality, the System logs automatically out. All users are affected.
  • Kicked out of the instance when clicking "OK" after choosing Proxy target

Reproducing the Issue

  1. Log in the instance as a user with Proxy rights (any user)
  2. Go to "Proxy Now" option
  3. Choose proxy target user (any)
  4. Click "OK"

Cause

  • Provisioning is incorrectly configured:
    • Main "performancemanagerX.successfactor.com" or ".eu" URL is included in the list named "Authorized Service Provider Assertion Consumer Services"
    • Or
    • Main "hcmX.sapsf.com" or ".eu" URL is included in the list named "Authorized Service Provider Assertion Consumer Services"
  • All URLs included in this list will receive a "log out" instruction for the current user when executing a proxy. This allow that same user log in as the proxied target.

Resolution

[You'll require access to Provisioning page to implement this solution or workaround.]
[Provisioning access is only granted to certified Partners and Support engineers.]
[If you don't have access, you may need to create a Support incident or request your Partner to refine your configuration.]
  1. Go in ProvisioningAuthorized SP Assertion Consumer Services
  2. Remove any unwanted Successfactors instance URLs from that list.
  3. "Save"

 

Keywords

booted out, kicked out, logged out, "proxy kick out", 'proxy kick out'  Proxy not working , KBA , LOD-SF-PLT , Foundational Capabilities & Tools , LOD-SF-PLT-SSO , Single Sign-on , Problem

Product

SAP SuccessFactors HCM Core all versions