Symptom
Users report that they are not receiving notification emails. These notifications are triggered from various APMs.
Environment
SuccessFactors Learning Management System - LMS
Reproducing the Issue
Run (or schedule) the APM background job for the related notifications that user's report not receiving.
Cause
There are no outgoing notifications for scheduled jobs (APMs) because the related admin account does not exist in the affected instance.
Resolution
Media not computed.
An LMS administrator will need to add or unlock the AUTO-SCHEDULER admin user.
- Access the Learning Admin UI.
- Click System Admin.
- Expand the Application Admin menu in the left navigation panel.
- Click Admin Management.
- Search for Admin ID AUTO-SCHEDULER - ensure the search criteria for Status is 'Both', to include both unlocked and locked users.
- If there is no such admin, then it will need to be added.
- If the admin user is found but locked, it will need to be unlocked.
- To unlock AUTO-SCHEUDLER > Edit account > Uncheck "Locked" > Apply changes
To add the admin user:
- Follow steps 1-4 outlined above.
- Click on Add New in the upper right corner.
- The admin user ID must be AUTO-SCHEDULER exactly.
- Ensure the domain is set to PUBLIC.
- Set a password.
- No other details need to be maintained.
- Click on Add.
To unlock the admin user:
- Follow steps 1-5 outlined above.
- Click on the edit icon to maintain the user.
- Uncheck the box for Locked.
- Click Apply Changes.
Keywords
email, mail, notifications, automatic process, issue, users, learning plan, expiration, overdue, none, send, receive, kal, kac , KBA , LOD-SF-LMS , SuccessFactors Learning , Problem