Symptom
- Timeout error when refreshing a report connecting to Salesforce.com
- When refreshing some report based on Salesforce.com in Crystal Reports, it fails with the error:
"Failed to retreive data from the database.
Details: HY000:QUERY_TIMEOUT:Your query request was running for too long. [Database Vendor Code: 117]"
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- Salesforce.com
Reproducing the Issue
- In Crystal Reports, create a report based on Salesforce.com
- When refreshing the report, it fails with the error:
"Failed to retreive data from the database.
Details: HY000:QUERY_TIMEOUT:Your query request was running for too long. [Database Vendor Code: 117]"
Cause
- When a query takes more than 2 minutes to be executed, it will fail with the query time out error, because Salesforce.com limit query execution to a maximum of 2 minutes.
- For reference regarding Salesforce.com limitations, see the Salesforce documentation on API Limits.
- Also, see the Salesforce Knowledge Article 7178 that describes a similar situation when querying Salesforce from an external application.
Resolution
- Some of the Saleforce suggestions are:
- Refine the filterring criteria to reduce the amount of data and execution of the query;
- Reduce the complexity of the query;
- If you are experiencing query time out error when reporting of Salesforce.com, consult the Salesforce support website, or contact Salesforce Support.
Keywords
SForce, CR, Saleforce, query timeout, query time out Crystal , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016