SAP Knowledge Base Article - Public

2270342 - Follow-up / Item Evaluation not sent following item completion

Symptom

Follow-up / Item Evaluation is not assigned to users after they complete the item the survey is associated to.

Environment

  • SAP HCM Suite
  • Learning Management System (LMS)
  • Admin interface
  • Evaluation/Surveys

Reproducing the Issue

1- Set the required item to trigger Follow-up / Item Evaluation upon the item completion

Followup_Evaluation.JPG


2- The item is completed by the user but the Evaluation is not triggered

Cause

  • Such an issue could be caused by a missing setting on the Completion Status level.
  • Another possible cause is that the Evaluation Synchronization APM is not scheduled and/or has errors.

    Systam admin > Automatic Processes > Evaluation Synchronization, the Evaluation Synchronization automatic process performs two tasks:
    1/ it sends survey assignment notifications for both Item Evaluations and Follow-up Evaluations
    2/ assigns Follow-up Evaluations to Users and their supervisors based on the assignment period configured for the Item.
    This automatic process uses the ItemEvaluationAssignmentNotification template to send Item Evaluation email notifications to the affected users and uses the FollowupEvaluationAssignmentNotification template to send email notification to Follow-up Evaluation participants.

Resolution

1- In LMS Admin, go to References>Learning>Completion Status
2- Search for the Completion Status used and click EDIT to open the record
3- Select the setting "Include leanring events with this completion status for Follow-Up Evaluation..." and click APPLY CHANGES.

Completion_status_1776.PNG

Keywords

SAP, SF, LMS, SuccessFactors, Followup, survey, completed, triggering, trigger, assigned, item evaluation, follow up , KBA , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-EVA , LMS Surveys , Problem

Product

SAP SuccessFactors Learning all versions