SAP Knowledge Base Article - Public

2266737 - Missing Approvals Link on User's Side in LMS

Symptom

User cannot see the "Approvals" in the Links tile section of the user interface within the SuccessFactors Learning Management System

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SuccessFactors Learning Management System

Reproducing the Issue

  1. Log in to the LMS instance, click on the Home tab
  2. The Approvals in the Links tile section are missing
  3. As a result, Learning cannot be approved

Cause

The Approval link is related to a workflow which was not assigned to the user role:

 Workflows.PNG

Resolution

The issue can be resolved by the following steps:

  1. Check what role is your User assigned to

CheckUserRole.PNG

  1. Navigate to SystemAdmin > Security > Role Management and narrow the search by role type: User
  2. Click on edit button for role specific role:

EditButton.PNG

  1. Click on workflows and then add one or more from list (to add the missing workflow to your role)
  2. Search for "access approval" and add it by checking the checkbox beside > ADD
  3. Then proxy as the user or navigate to your HOME tab to confirm the link is now available:

Approvals.PNG

Keywords

missing approvals link, Supervisor cannot approve learning, links tile, user interface, SF Success Factors, LMS , KBA , LOD-SF-LMS-ADM , Admin Tools , Problem

Product

SAP SuccessFactors Learning all versions