SAP Knowledge Base Article - Public

2258435 - Error "HTTP Status 401 – The authentication of the user failed" while running Ad Hoc reports online

Symptom

  • Certain users receive the below error when running Ad Hoc reports online:

    Error.png
  • Exporting the report offline as CSV will fetch expected results

Environment

  • SuccessFactors HCM Core
  • Ad Hoc Report

Reproducing the Issue

  • Navigate to 'Ad Hoc reports' in the Reports Center as the affected user
  • Click any report and select 'Run Report'
  • Choose the 'Run Online' option and Generate the Report

Cause

  • Lack of 'User Login' permission in RBP
  • Locked User account

Resolution

  • Modify 'General User Permission'
    Admin Center> Set User Permissions>  Manage Permission Role> Select the desired Role> General User Permission
  • Grant 'User Login' permission and save the changes
    Fix.png
  • The user will have to re-login for the changes to take effect
  • In admin Center, there is link called “Reset user account"

  • If it is showing cancel icon in red colour, reset the user account which will change to tick mark in green colour

Keywords

HTTP Status 401 Ad Hoc - The authentication of the user -  User is not able to run reports Adhoc, HTTP Status 401, Authentication , KBA , 401 ad hoc , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem

Product

SAP SuccessFactors HCM Suite all versions