SAP Knowledge Base Article - Public

2251980 - Invalid IP format error when setting API Login Exceptions

Symptom

Invalid IP format error is released when setting IP address (range) in API Login Exceptions in Admin tools - Password & Login Policy Settings

KBA.PNG

Environment

SuccessFactors BizX

Reproducing the Issue

  1. Go to Admin tools -> Password & Login Policy Settings
  2. Click on 'Set API Login exceptions...' link
  3. Add new or Edit actual User security settings
  4. Fill in Username, Maximum password age (days), IP Address Restriction: IP address or IP address range
  5. Save and receive 'Invalid IP format' error

Cause

IP Address provided in 'IP Address Restriction' field is in incorrect format

Resolution

Make sure that you provided IP address in valid format. IP address (IPv4) consists of four numbers separated by dots. Range for each of the numbers is from 0 to 255. Example of IP address in valid format: 127.0.0.1

See Also

See KBA 2161058 for more information on API Login exceptions

Keywords

API Login Exceptions, IP address, API user, whitelist, integration , KBA , LOD-SF-INT , SF Integrations - EC Payroll, Boomi/ HCI, API , Problem

Product

SAP SuccessFactors HCM Suite all versions