2250862 - "No screen exists" error in Document Generation

SAP Knowledge Base Article - Public

2250862 - "No screen exists" error in Document Generation

Symptom

Error  "No screen exists for this object type; contact your system administrator to resolve this issue" while navigating to manage document template page

Environment

SuccessFactors Employee Central V2

Document Generation

Reproducing the Issue

Navigate to admin center---->  Manage Document Template----> select Document Generation Template ---->below error appears.

"No screen exists for this object type; contact your system administrator to resolve this issue."

No screen exists.png

 

Cause

Document generation screen Look Up  is not added in manage data or screen id inside 'Document Generation Template' is empty.

Resolution

Pre-delivered Configuration UI screens provided by the Product Management team are available in the Success Store.

Import them using 'Import and Export Data" admin tool.

success store.png

Or, Go to Admin Center - > Manage Data -> Create New -> Document Generation Screen Look Up -> In the "Object Type" drop down select "Document Generation Template" and in the "Screen ID" select an existing screen id (imported via success store).

Saved.png

In case it is empty, Go to Admin Center-> Manage Configuration UI -> Create New-> Provide a name for "Id" -> "Select Base Object" select "Document Generation Template". -> Click on Save.

manage config UI.png

Enter this ID to the Screen Id of Document Generation Screen Look up. Default name of the UI is "DocumentGenerationOverviewConfigUIMeta".

Keywords

SuccessFactors Employee Central V2 Document Generation No screen exists , KBA , successfactors , employee central , document_generation , error_no_screen_exists , LOD-SF-EC-DOC , Document Generation , Problem

Product

SAP SuccessFactors HCM Core all versions