Symptom
Customer is running the User Connector - SF connector but the users' timezone and currency is not updating.
Environment
SuccessFactors Learning Management System (LMS) - All Supported Versions
Cause
This issue happens because the feature sfuser.connector.update.updatePreferences is set to "N" in the Connector Properties.
Resolution
To update Currency and Time Zone fields via connector, admins will need to change the value of the feature sfuser.connector.update.updatePreferences from N to Y. To do so you will need to:
- System Administration > Configuration > System Configuration > Connectors
- Do a CTRL + F and search for sfuser.connector.update.updatePreferences
- Set it to Y
- Click on "Apply Changes"
Before loading the user data file, please also make sure to configure the features below with the value that the users will be updated with.
- sfuser.connector.defaultValue.preferenceTimeZone=
- sfuser.connector.defaultValue.preferenceCurrency=
Please make sure that these values exist in your LMS or the connector will reject the users records.
NOTE: Same thing applies to User Connector >> user.connector.update.updatePreferences=Y & the Admin Connector >> admin.connector.update.updatePreferences=Y
See Also
3085902 - Fatal error updating User Timezone field not being Updated via connector
Keywords
user connector sf, update preferences, timezone and currency, sfuser.connector.defaultValue.preference, sfuser.connector.defaultValue.preferenceTimeZone, sfuser.connector.defaultValue.preferenceCurrency, sfuser.connector.update.updatePreferences , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS , Learning Management System , Problem