SAP Knowledge Base Article - Public

2248237 - Permission role is not saved due to Error

Symptom

When creating/updating a Permission Role in Role-Based Permission, the following errors may occur:

  1. Pop-up with error message: "Error updating permission role [roleId=0]";
  2. Application error with fingerprint: "a805de7b902b0b7af6f5c7e535d8977502eb9f98".

Environment

SAP SuccessFactors BizX Platform

Reproducing the Issue

  1. Access your instance with an admin user;
  2. Go to admin center > Manage Permission Roles;
  3. Create or edit a permission role;
  4. Enable permissions;
  5. Click on Done button to save it;
  6. You will face one of the errors mentioned above.

Cause

This is caused by database inconsistencies.

Resolution

In order to solve the issue, you need to create an incident with Cloud Product Support under component LOD-SF-PLT-RBP.

On our end, we will refresh the Role Based Permission and this action should trigger an update on the database that will solve the issue.

In case this solution do not work, we might require the engagement of our Engineering team to further investigate.

Keywords

not saving application error , KBA , LOD-SF-PLT-RBP , Role Based Permissions , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors HCM Suite all versions