SAP Knowledge Base Article - Public

2247095 - Missing data when reporting off a Salesforce.com Stored Procedure in Crystal Reports 2013

Symptom

  • Missing data.
  • Not all the rows are displayed on the report.
  • When reporting off a Salesforce.com Stored Procedure in Crystal Reports 2013, it only returning all the records.
  • In Crystal Reports 2011, and below, when reporting off the same Salesforce.com Stored Procedure it always returns the expected data set.

Environment

  • SAP Crystal Reports 2013
        
  • Salesforce.com

Reproducing the Issue

  1. In Salesforce.com, create a report off the table that returns a large number of records.
  2. In Crystal Reports 2013, create a new report off the same Salesforce.com Stored Procedure.
  3. Refresh the report in Crystal Reports 2013, and notice it is missing records.

Cause

  • The specific Salesforce.com API used, as a limit of 2,000 rows when connecting to a Salesforce report (Stored Procedure), and this is why not all the data are displays on the report.
  • This situation has been reproduced at SAP, and tracked under SAP Note 2132655

Resolution

  • The issue is resolved in the following product updates:
              
    • Crystal Reports 2013:
      • Support Pack 05 - Patch 4
      • Support Pack 06 and above
           
  • Important Note:
    A new option was added to the Salesforce.com logon, called "Use Analytic API". This option enable you to select which Salesforce.com API to use when connecting to a Salesforce.com Stored Procedure.
    - If the option is unchecked (False), it will display all the rows data. ( Default Value )
    - If the option is checked (True), it will use the Salesforce.com Analytic API, which is limited to return up to 2000 rows of data,
      but the advantage is the column type would be more precise

Keywords

SForce, CR, Saleforce, Stored Procedure, SFDC , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Bug Filed

Product

SAP Crystal Reports 2013