SAP Knowledge Base Article - Public

2243647 - Problem (User Handling) - US Form I-9 Section 2 is Blank in New Hire's Onboarding Activity Due to I-9 3 Business Days Process - Onboarding [US I-9] [Forms]

Symptom

US Form I-9 Section 2 is blank in New Hire's Onboarding Activity

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to SAP SuccessFactors HCM > Onboarding
  2. Find the candidate's activity and under PDF forms see US I-9 Form Section 2
  3. Data is no populated in the form

Cause

Orientation Step Not Completed

During the Orientation Step, if the new hire did not bring the eligibility document; Assignee answered 'No' to the following question: Does the employee have the proof of eligibility document(s) with him or her today? (Find screenshot below). If the answer is equals to No the Orientation Step is considered not completed and it will not let the manager proceed further, the workflow will stop and  I-9 3 Business Days process will start. It is an expected behavior for Section 2 to not populate the detials as Orientation is not completed. (See KBA 2149121)

In addtion, the data key MA_I91_HaveDocuments is equals to No if the question is mentioned above is No as well. 

2018-09-18_3-33-27.png

Resolution

For Live Customer(s), Implementation Partner(s), and Consultant(s)

Self-diagnosis

  • Open Onboarding Dashboard and under I-9 3 Business Days Work Queue find the new hire's activity
  • Run an Advanced Report with the key MA_I91_HaveDocuments if the new hire's key is equals to No I-9 3 Business Days workflow should trigger if enabled (See KBA 2161955 on how to run an Advanced Report)

Next Action

  • MA_I91_HaveDocuments is equals to No and no I-9 3 Business Days workflow triggered for the new hire, see KBA 2686327
  • MA_I91_HaveDocuments is equals to Yes and I-9 3 Business Days workflow is expected to not trigger, see KBA 2273389

 

For SAP SuccessFactors Cloud Product Support

Please use the instruction manual on how to proceed, in the internal KBA 2633075

See Also

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Keywords

SAP SuccessFactors, Onboarding, OBD, ONB, LOD-SF-OBD, DHS, United States Department of Homeland Security, United States Citizenship and Immigration Services, USA, United States of America, Verification, Verify, Employment, I-9, I9, SSA, Social Security Administration, Authorized, Work, Panel, Process, I9 3 Business days, 72 Hour, WOTCStartDate, MA_I91_HaveDocuments equals to No, problem, difficulty, trouble, worry, complication, difficult situation; snag, hitch, drawback, stumbling block, obstacle, hurdle, hiccup, setback, catch; predicament, plight; misfortune, mishap, misadventure; a dilemma, quandary; information, details, particulars, facts, figures, statistics, data; knowledge, intelligence, instruction, advice, guidance, direction, counsel, enlightenment, news, word, hot tip, solution, answer, result, resolution, way out, fix, panacea; key, formula, explanation, interpretation , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions