SAP Knowledge Base Article - Public

2242282 - Blank or empty page when selecting Analytics Sub-Tab

Symptom

When you access the instance and select the Analytics sub tab, the Online Report Designer (ORD) page is not loaded although it used to work before and you have the correct permission for it.

For example:

Blank or empty pag

Environment

  • SuccessFactors HCM Core   
  • ORD

Reproducing the Issue

  1. Login to the desired instance
  2. Analytics - Analytics
  3. Just an empty page is shown under Analytics sub-tab

Cause

1. URL not set in provisioning for ‘Authorized SP Assertion Consumer Service Settings’.

In this case in the Company Settings: WFA – the Single Sign On (SSO) was configured and all look fine but when accessing the Analytics tab, it return an empty page. 

2. As a result of an instance refresh the reverse proxy URL has been copied over. Currently there is no reverse proxy (Akamai) available for the preview stacks.

Resolution

1. In this case the issue was caused by the missing values for Assertion Consumer Service and Logout Url from Authorized Service Provider Assertion Consumer Service.

We were able to solve the issue by adding the correct details as below:

Provisioning > choose company > Service Provider Settings > Authorized SP Assertion Consumer Service Settings.

*replace the XXX with the respective number based on your data center.

NOTE: You can check the SSO implementation guide to get the up to date configuration settings to use.

2. Removing the incorrect reverse proxy URL in Provisioning. 

Provisioning > choose company > Company Settings > Search for 'Reverse Proxy Url Prefix'

Keywords

  • Analytics
  • Online Report Designer
  • ORD
  • ODS
  • Advanced Reporting
  • Reporting
, KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM Core all versions

Attachments

Empty page when selecting Analytics Tab.docx