SAP Knowledge Base Article - Public

2227861 - Company Org Chart Error

Symptom

  • User opens Org Chart and is prompted with an error;
  • User who recently transferred to a new manager is not displayed as a direct report of their new manager;
  • Selected user in org chart has invalid direct/upper levels manger;
  • Search for user in Org chart and get error  "Could not retrieve data for this user, please try again later or notify support (errorid = **********)"
  • Search for user in Org chart and get error  "Unable to load data for this user due to a backend job lag (errorid = **********)"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

Scenario #1: 

  1. Go to Company > Org Chart;
  2. Application Errror will show-up: 

    "Could not retrieve data for this user. Please try again later, or notify support (with the error information of errorId={errorID x}, timestamp={timestamp y}, and the version information from the current screen) if the issue keeps occurring."

    2227861 Capture.PNG

    "Unable to load data for this user due to a backend job lag. Please try again later. If the error keeps occurring, contact your system administer. The error ID is {errorID x}. The time stamp is {timestamp y}. To know more about this error, see https://launchpad.support.sap.com/#/notes/2227861."

      ''

Scenario #2:

  1. Go to Org Chart;
  2. Choose "One Level Up" button from the Org Chart display.
  3. The Org chart will show the manager and some direct reports but not the employee you started with in the search

    Note: When navigating to the employee information screen the manager is listed correctly for the effected user.

Cause

This error message may be caused by a loop in the hierarchy or invalid/inactive users in upper level hierarchy. Org Chart does not support loops in the hierarchy.

This is expected in a condition like one of the following:

  • The user is inactive
  • The user is not yet Hired (this only applies to Employee central enabled instances)
  • LnR job did not yet execute for the company (where the job runs on a particular scheduled basis)
  • The user doesn't have a valid manager, example user A's manager is specified as B, but B is not a valid user, so user A will not get a LnR record
  • The user is part of a cyclical manager relationship, example: user A's manager is B, B's manager is C, C's manager is A - in this case user A, B, and C will not get a LnR record

Note: The LnR job is a job designed to refresh user relationships so that the Org chart can show the latest changes. The LNR job is triggered every hour., this is a backend job and cannot be controlled from Provisioning.

Resolution

Steps to take to resolve this issue:

  1. Use the check tool to check the User Hierarchy is correct to do this navigate to Check Tool -> User Management-> Hierarchy - See KBA 2472648 Check Tool: How to check your SuccessFactors configuration.

    • You can use it to check whether an active manager and second manager exist for a selected user. The Manager and Second Manager fields should be either an existing and active User ID in the system or "NO_MANAGER".
    • * Note: Check User Hierarchy in User Directory File(UDF) with text editor program such as Notepad++. The userID may have leading zeros that are not defined in ManagerID column which will get removed in Microsoft Excel*
    • You can use it to check whether manager cycles or second manager cycles exist for a selected user. If manager cycles are found, the check will return errors, together with the names of managers that are in cycle so you can update them to break the cycles.

  2. If the Hierarchy is correct you should perform a basic user information import, which has the effect of manually triggering the LnR process. You only need to import a single record with a manager change. We recommend using an "admin" user account in the import file since it resides outside the official employee hierarchy.

For more information on how to perform the employee export and import, please visit SAP Help Portal page: Managing Basic User Data by Using a Data FileAfter the import process has completed, check the Org Chart to ensure that the management changes and the manager transfer is reflected for the problem users.

See Also

  • 2472648 - Check Tool: How to check your SuccessFactors configuration
  • 2085492 - Company Org Chart - Overview and Configuration Options

Keywords

Org Chart , LNR job, error , User Hierarchy, Unable to search user in org chart , Company Org Chart Refresh, unable to see user in org chart , errorCode=3 , errorCode=1 , KBA , LOD-SF-PLT-ORG , Org Chart Issues , LOD-SF-EC , Employee Central , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-SCM , Succession Management , Problem

Product

SAP SuccessFactors HCM all versions