2222729 - Assertion failed: invalid field structure for data model OR Assertion failed: item added is invalid(from DataModelSectionView)

SAP Knowledge Base Article - Public

2222729 - Assertion failed: invalid field structure for data model OR Assertion failed: item added is invalid(from DataModelSectionView)

Symptom

  • Assertion failed messages when accessing a permission role in Role Based Permissions.
  • Assertion failed: invalid field structure for data model.
  • Assertion failed error while making changes to the permission roles.

Environment

SuccessFactors Cloud HCM.

Reproducing the Issue

  1. Logon to the instance.
  2. Navigate to Admin Center > Set User Permissions > Manage Permission Roles.
  3. Permission Role List screen shows all the roles in the system.
  4. Click any permission role.
  5. While loading the screen Permission Role Detail, system gives error message stating 'Assertion failed: invalid field structure for data model'.

 

error_assertion.PNG

Cause

  • The error on RBP mainly occurs due to configuration issue in the data model specific to company instance.
  • Any kind of misconfiguration may lead to such error message.
  • For example - Two elements in data model are having same id or few fields are expected to have at least a value which is not in place.

Resolution

INSTRUCTIONS FOR PARTNERS:

  • Review data-model configuration for elements with duplicate ID's.
  • A common mistake made would be to have a background-element and a standard-element with the same ID in the data-model. Example:

    • One standard element:
      <standard-element id="talentPool" required="false" matrix-filter="false">

    • Further down, a background-element with same ID:
      <background-element id="talentPool" type-id="60">
  • If a duplicate element ID has been found, amend one of the ID's and re-import the data model.

CUSTOMERS WITHOUT PARTNERS:

  1. Customers are requested to log an incident following the published guidelines with snapshot of the error screen.
  2. As the error could be very specific to the instance, it is mandatory that SuccessFactors support staff reproduces the issue.
  3. Support staff will work with respective engineering team to identify the root cause and inform customer about the error in configuration.
  4. Upon confirmation, customer must provide written approval to make required changes 

Keywords

  • RBP - Role Based Permissions.
, KBA , LOD-SF-PLT-RBP , Role Based Permissions , Problem

Product

SuccessFactors HCM Suite 1207 ; SuccessFactors HCM Suite 1210 ; SuccessFactors HCM Suite 1302 ; SuccessFactors HCM Suite 1305 ; SuccessFactors HCM Suite 1308 ; SuccessFactors HCM Suite 1311 ; SuccessFactors HCM Suite 1402 ; SuccessFactors HCM Suite 1405 ; SuccessFactors HCM Suite 1408 ; SuccessFactors HCM Suite 1502 ; SuccessFactors HCM Suite 1505 ; SuccessFactors HCM Suite 1508