2210781 - External candidates are not receiving password reset email

SAP Knowledge Base Article - Public

2210781 - External candidates are not receiving password reset email

Symptom

External candidates are not receiving password reset email because there is no template configured on the instance for a specific language.

Environment

SuccessFactors Recruiting Managament (RCM) - All versions

Reproducing the Issue

Reproducing the issue:

1 - Navigate to external career site

2 - Click on "Sign In" and "Forgot your password?"

3 - Type your e-mail address and no notification is received

Cause

There is no email template configured for the language that the candidate is using on external career site.

Resolution

You should verify existing email templates on your instance and certify that they are configured for each language being used on your external career site.


For example: If there are three languages that candidates can use and these languages are English, Spanish and Italian, you must create a template for English, Spanish and Italian. If candidates are using Italian as language and there is no template setted for it, they will not receive any notification.

 

1 - Navigate to "Options" on your instance:

options.png

 

2 - Verify what is the language:

language.png

 

3 - Access "Recruiting Email Triggers" on Admin Tools:

 

admin tools.png

 

4 - After doing these steps, click on "Career Site Password Reset for external candidates".

5 - Check if there is an existing template for this specific notification. If the required template does not exist, a message will appear containing the following content: "Email Template is not configured in your locale".

 

incorrect template.png

 

If the email template is configured correctly, you will be able to view it:

 

correct template.png

 

Then, after confirming that the issue is being caused because there is no e-mail template created, you can navigate to "Manage Recruiting Email Templates" and create one for the desired language.

 

recruiting email templates.png

 

Please note that there are a lot of causes that can impact this problem regarding reset password feature, however, most of them can be fixed following the steps above.

Keywords

External candidates are not receiving password reset email because there is no template configured on the instance for a specific language External candidates are not receiving password reset email Email notification Reset password feature Password reset email   , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions