2202541 - An Application Error has Occurred - NumberFormatException error

SAP Knowledge Base Article - Public

2202541 - An Application Error has Occurred - NumberFormatException error

Symptom

When trying to either update employee data via Take Action (MSS UI) or when trying to Hire/Rehire an employee, you encounter "An application error has occurred. erroId".

The errorId is always unique.

Please note, customers will not be able to identify the error directly as Product Support need to recover this from application logs. So, if you are a customer and encountering an Application Error when saving data to an EC portlet, please raise an incident with Product Support. These errors are typically configuration or data related.

Environment

Employee Central 2.0

Reproducing the Issue

1) Make a change to Job Info for an existing user via Take Action (MSS UI), or, the same error can occur when saving a new hire/rehire, or even when appoving a workflow to create a new hire/rehire
2) Collect the errorId that is generated when saving
3) Search for the errorId in the logs
4) The error returned is -:

com.successfactors.sca.ServiceSystemException: Remote Exception: For input string: ""; nested exception is:
java.lang.NumberFormatException: For input string: ""

Cause

The NumberFormatException occurs if you have either -:

  • Configured a picklist for a numeric field
  • Non-numeric data being saved to a numeric field
  • Number format that is not accepted by the field

Resolution

This is a configuration issue, usually encountered during implementation, and most likely due to assigning a picklist to a numeric/foundation field. For example, assigning a picklist to a Foundation Object field or system field that is of type numeric. Usually you would only assign a picklist to a system defined field if specified in the Implementation Handbook, otherwise picklists should only ever be mapped to custom-string fields

1) Edit data for an existing employee in each of the possible non-MDF related sections of the Take Action (MSS UI) menu - this can help determine which hris-element is related to the error

2) Once you have identified the element that the error occurs in, export the Succession Data Model and Country-Sepcific Data Model and review that hris-elements configuration. Be sure to check fields that have picklists assigned, against the EC Implementation Handbook to verify each fields configuration.

3) If you are unable to determine the field, you could also try removing all picklist mappings from that hris-element section, and then add them back 1 at a time until you can reproduce the error

ALWAYS TAKE A BACKUP OF THE CONFIGURATION FILE.

Keywords

NumberFormatException An Application Error Job Information error , KBA , LOD-SF-EC , Employee Central , LOD-SF-EC-SER , Config. Consulting & Service Requests , Problem

Product

SAP SuccessFactors HCM Core all versions