SAP Knowledge Base Article - Public

2187182 - LMS Audit Reports Run Button Not Displayed

Symptom

  • Administrator can't run LMS audit report
  • The Learning Audit Report run button is missing
  • The run button for an Learning Audit Report in SuccessFactors Learning Management System is not being displayed for the administrator in order to execute the report for auditing purposes.

Environment

SAP SuccessFactors Learning Management System

Reproducing the Issue

  1. Log in as an admin
  2. Go to Reports
  3. Search for the audit report needed (make sure to have checked the box "Audit")
  4. Click on the report
  5. The "Run" button is not present

Cause

  • Audit reports processes huge amounts of data, hence it is strongly recommended to do not run them directly.
  • Instead schedule and let them run in background.
  • Running the report in the foreground can cause system instability and performance issues.

Resolution

Audit reports are recommended to run scheduled only; however if you want to override the functionality the following is needed:

  1. Go to System Admin
  2. Configuration
  3. Then System Configuration
  4. Click on the edit button in REPORT_SYSTEM
  5. Look for the line "scheduleOnlyReports" and noticec the list of Audit Reports, the report ID will be after the "scheduleOnlyReports.", E.G. for the Scheduled Offering Enrollment Audit (CSV) report, the line will be "scheduleOnlyReports.ScheduledOfferingEnrollmentAuditCSV"
  6. Set the value to "false" to activate the "Run" button
  7. Click on Apply Changes.

Keywords

SF, success factors, audit report , KBA , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-REP , Reporting Data , How To

Product

SAP SuccessFactors Learning all versions