SAP Knowledge Base Article - Public

2180909 - For how long are the SFAPI Audit logs available?

Symptom

Logs in SFAPI Audit logs are not available.

When attempted to download audit logs, The below error is seen.

purged logs.jpg

 

Environment

SuccessFactors

Reproducing the Issue

Navigate to Admin Tools - SFAPI Data Dictionary - Click on the icon below "SOAP" (Screenshot attached below)

 

audi222.jpg

 

 

Cause

If the Audit log which is being downloaded/viewed is older than the 10,000th log, The message of the log would be purged.

Resolution

This is system behavior.

The Audit log setting is defaulted to 10,000 in the backend ie., Maximum message body count is 10,000 and Maximum log count is 1000000.

See Also

Frequently asked questions:

1) Can the setting be enhanced so as to store more logs? - No

2) Can operations or other SAP teams help in retrieving lost logs? - No 

Keywords

Audit logs purged , sfapi audit logs , KBA , LOD-SF-INT , SF Integrations - EC Payroll, Boomi/ HCI, API , How To

Product

SAP SuccessFactors HCM Suite all versions