2166762 - User previously deleted from an instance cannot be imported again via User Connector - SF

SAP Knowledge Base Article - Public

2166762 - User previously deleted from an instance cannot be imported again via User Connector - SF

Symptom

** UPDATE: This  feature was removed in 1708, but will be available in 1708 Patch 12 again. Please see KBA 2123766 for more information on the restoration of this feature**

Users previously deleted from an instance can not be imported again via User Connector SF

Environment

SuccessFactors Learning Management System (LMS) - All Supported Versions

Reproducing the Issue

  1. Create several users in LMS
  2. Go to Each user record and click on delete in the 'Actions' section
  3. Run User Connector SF to import users from BizX
  4. The import fails wiith the error 'The User ID does not exist but an old record exist for this User ID. This means that this User existed at some point and has been deleted. You may not re-use this User ID for a new User'

Cause

The setting in the Connector configuration file in LMS Admin has been set to prevent the reusing of deleted User IDs

sfuser.connector.deletedUser.reincarnate=N

Resolution

Navigate to the following location in LMS Admin:

System Admin >> Configuration >> System Configuration >> Connectors

Change

'sfuser.connector.deletedUser.reincarnate=N'

to


sfuser.connector.deletedUser.reincarnate=Y

Run the connector again and the users will be imported into the instance.

Keywords

error, 226005, warning, Warning Details, reincarnate user ID, administrator, The User ID does not exist, old record, sfuser.connector.deletedUser.reincarnate , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning all versions