Symptom
- Unable to connect to Salesforce.com Sandbox.
- When attempting to connect to a Salesforce.com Sandbox from Crystal Reports 2013, it fails with the error:
"Login failed: HY000:INVALID_LOGIN:Invalid username, password, security token; or user locked out.
[Database Vendor Code: 58]"
- It is possible to connect to the same Salesforce.com Sandbox from Crystal Reports 2011 and below.
Environment
- SAP Crystal Reports 2013
Reproducing the Issue
- In Crystal Reports 2013, create a new report, and in the "Database Expert", select "Salesforce.com"
- In the "Salesforce.com" window, enter the Salesforce.com Sandbox server to connect to, as well as the user credentials.
- When clicking "Finish" to connect, it fails with the error:
"Login failed: HY000:INVALID_LOGIN:Invalid username, password, security token; or user locked out.
[Database Vendor Code: 58]"
Cause
- When connecting to Salesforce.com, Crystal Reports 2013 is always connecting to: www.salesforce.com url, regardless of the url entered in the Salesforce.com connection. This is why it fails to connect to a Salesforce.com Sandbox.
- This issue has been reproduced at SAP and tracked under SAP Note 2111879
Resolution
- The issue has been resolved in the following product updates:
- SAP Crystal Reports 2013:
- Support Pack 04 - Patch 8
- Support Pack 05 - Patch 4
- Support Pack 06
Keywords
CR, sandbox, domain, sforce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed
Product
SAP Crystal Reports 2013