2161834 - Unable to Connect to Jam. Please Verify your Jam Integration setting and connectivity whilst adding Jam Groups to an item in LMS

SAP Knowledge Base Article - Public

2161834 - Unable to Connect to Jam. Please Verify your Jam Integration setting and connectivity whilst adding Jam Groups to an item in LMS

Symptom

After Integrating Jam into LMS, administrators are still not able to search catalog or add Jam groups to Items.

When searching catalog, you see this error

catalog search.png

When adding Jam Groups to an item this error is displayed

add Jam Groups to item.png

 

Environment

SuccessFactoirs LMS

Reproducing the Issue

Prerequisites to integrate JAM with the LMS should be met:

  1. JAM and BizX must be integrated
  2.  BizX and LMS must be integrated

Configuration On the LMS side (System Admin>Configuration>System Configuration>LMS_ADMIN)

Changes to LMS_ADMIN config file:

  • jamIntegrationEnabled = true
  • enableCatalogFilteredSearchAndIntegratedSocialContent=true

Changes to BizX config file with the  (System Admin>Configuration>System Configuration>BizX)

  • successFactorsCubeTreeBaseURL='according to the correct server mapping'

example:

successFactorsCubeTreeBaseURL=https://jamXX.sapjam.com

(where XX is the data center the customer server is located)

 

Cause

The Jam API has not been Enabled in JAM Admin settings

Resolution

  • In BizX home page Home > JAM > Admin Settings>Features.
  • Scroll to Feature Management
  • Make sure that “Enable API” is checked.

Enable API.png

(Disabling the API feature will prevent access to your Jam environment via the Jam API and will prevent access using the mobile clients)

Keywords

KBA , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-INT , SF Integrations - EC Payroll, Boomi/ HCI, API , LOD-SF-JAM , SAP Jam , Problem

Product

SAP SuccessFactors Learning all versions