SAP Knowledge Base Article - Public

2160652 - Unable to display Userinfo fields with Ad Hoc reports

Symptom

You want to report on an Userinfo-element field you have configured in your data model/XML template although it is not available from the column list within the Ad Hoc report.

Environment

  • SuccessFactors HCM Core     All versions
  • Reporting

Reproducing the Issue

  1. Succession Management - Import/Export Data Model
  2. For this example, you have configured a Data Model which contains an Userinfo field as below:
    • <userinfo-element id=" FIELDNAME " type="varchar" required="false">
    • <label> FIELDNAME </label>
    • <label xml:lang="en-US"> FIELDNAME </label>
    • </userinfo-element>
  3. The field is available and used via the Employee Profile portlet.
  4. When you create an Ad Hoc report based on the Employee Profile domain you cannot find this field anywhere.
  5. You notice that both standard and custom fields are available from the Column List.

Cause

Report behaviour is as designed. Configuration issue.

Resolution

The reason why the field is not visible in the report/columns is because the way the data model/XML template was configured.

In this case you should be able to solve this issue by adding reportable="true" into the data model for the userinfo fields which you want to be reportable. For example:

  • <userinfo-element id=" FIELDNAME " type="varchar" required="false" reportable="true">
  •    <label> FIELDNAME </label>
  •    <label xml:lang="en-US"> FIELDNAME </label>
  • </userinfo-element>

NOTE: There is a limitation of 30 UserInfo fields to be set as reportable.

Keywords

Userinfo-element , KBA , userinfo-element , reportable , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, ORD) , How To

Product

SAP SuccessFactors HCM Core all versions