SAP Knowledge Base Article - Public

2156650 - Capture network traces with Internet Explorer Developer Tools (F12)

Symptom

  • This guide shows how to collect network traces with IE9/I10/IE11 Developer Tools.
  • There is no needs to install any additional software as it is a tool integrated in Internet Explorer.
  • Network traces are needed to analyse communication between IE browser on user machine and  server.

Example of troubleshooting:

  • Check scorm communication between course and LMS for completion problems
  • Identify request and response causing latency in performance problem

Environment

  • SuccessFactors Learning Management System (LMS) - All Supported Versions
  • Internet Explorer 9,10,11

Cause

Network Traces are needed by CS to analyze the communication between browser and server

Resolution

1. Open IE Developer Tools

Make sure IE is opened, on your keyboard, press F12 (or Tools->F12Developer Tools )

It opens a new window ‘Home F12’, Go on Network tab

ie_1.PNG

 

2. Access Network section

Click on Network tab, you should see ‘Start capturing button’ with clear table.

ie_2.PNG

3. Start Capturing before replicating the issue

Click ‘Start capturing’ (button switches then to ‘Stop Capturing’)

ie_3.PNG

 

4. Replicate the issue

Replicate the issue (ex: course completion problems, course freezes, timeout issues…), the table should be populated by traces.

ie_4.PNG

 

5. Stop capturing Once you finished to replicate the issue, click ‘Stop capturing’ (the button switches back to ‘Start capturing’).  

ie_5.PNG

 

6. Export traces

Click on the purple floppy disc icon, and export 2 Files: - The csv file to save the traces overview - The xml files to save the traces detailed view

ie_6.PNG

 

7. Attach the 2 files in the case

ie_7.PNG

 Thanks for your cooperation!

Keywords

Network Traces, Internet Explorer, LMS, logs , KBA , LOD-SF-LMS-INT , LMS Integrations , How To

Product

SAP SuccessFactors Learning all versions