SAP Knowledge Base Article - Public

2149121 - Fields in Section 2 of US I-9 Form is Empty or Blank After Activity is Completed - Onboarding 1.0 [US I-9] [System Behavior]

Symptom

Why does the US I-9 form Section 2 is not populated after Onboarding activity is now in 'All Documents Submitted' status in Work Queue?

Environment

SAP SuccessFactors Onboarding 1.0 - All Versions

Cause

The data key (MA_I91_HaveDocuments) is populated with a value equals to "No"

Resolution

Proof of Eligibility not Provided in Orientation Step

  • During the Orientation Step, if the new hire did not bring the eligibility document; Corporate Representative (Assignee) will answer 'No' to the question: Does the employee have the proof of eligibility document(s) with him or her today? 
  • If the answer is equals to "No" the Orientation Step is considered not completed and data key (MA_I91_HaveDocuments) is populated with a value equals to "No"
  • In addition, it will not let the manager proceed further with the workflow and will stop Onboarding activity by not generating an E-Verify.
  • US I-9 3 Business Days process will start after Onboarding actiivty is under All Document Submitted Status

screenshot0039_ 04142019100607.png

 

Having Trouble?

No US I-9 3 Business Days workflow/process created? See KBA 2243647

 

Learn More...

Want to know more about US I-9, Employment Eligibility Verification, see KBA 2380523.

Keywords

SAP SuccessFactors, Onboarding 1.0, System Behavior, Expected Behavior, System As Designed, United States of America, US, USA, I9, I-9, Form I9, Blank, bare, empty, missing, Not Populated , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , How To

Product

SAP SuccessFactors Onboarding all versions