2130222 - No Payment Created Though Payment Block has Expired - Customer Blocked for Payments

SAP Knowledge Base Article - Public

2130222 - No Payment Created Though Payment Block has Expired - Customer Blocked for Payments

Symptom

After executing the payment run for receivables you get the message XXX blocked for payments.

A payment block has been maintained for the particular customer, but the expiry date of the payment block is earlier than the execution date of the payment run.

Reproducing the Issue

  1. Open Receivables Work Center
  2. Navigate to Payment Runs
  3. Create a New - Payment Run
  4. Flag the box Execute Payments Automatically
  5. Go to Schedule Job  and start/schedule the job accordingly
  6. Alternatively select an already existing Run ID and proceed as described above
  7. After the execution of the run open the Application Log
  8. Go to the tab Results
  9. Choose the button Expand All
  10. For Payer XXX you get the message: XXX blocked for payments

 

  1. Open Receivables Work Center
  2. Go to Customers - Customer Accounts and select the Customer Account XYZ
  3. Click on View - View All
  4. Navigate to the Financial Data - Payment Data tab
  5. You see that a Payment Block has been maintained with a Payment Block Expire Date earlier than the execution date of the Payment Run

 

Cause

If you flag the Execute Payments Automatically box for in the payment run there will be no payment proposals which can be processed manually by the user. All payments are going to be processed and posted automatically on the respective G/L accounts. Therefore, to avoid the that payments are unintentionally created and posted, because a user forgot to extend the expiry date of the payment block, the payment block will even be considered when the expiry date is earlier than the execution date of the run.

 

 

Resolution

This is the expected system behaviour.

To have payments for customer XYZ considered for payments the row with the payment block has to be deleted from the customer's account:

  1. Open Receivables Work Center.
  2. Go to Customers - Customer Account and select the Customer Account XYZ.
  3. Click on View - View All.
  4. Navigate to the tab Financial Data - Payment Data.
  5. Select the row containing the Payment Block and click on Remove.
  6. Confirm with Save.

Keywords

KBA , SRD-CC , Cross Components , How To

Product

SAP Business ByDesign all versions