SAP Knowledge Base Article - Public

2089368 - Error - User Import Error - Invalid Manager ID - Platform

Symptom

  • User Import Errors.
     
  • When uploading a user import file, the email notification displays the following error message:

    Failed to add/update user >userID###] "USERNAME"

    (Dept;Div;Location): Manager Cycle detected with this

    manager Id - "Manager userID"

Environment

  • SAP SuccessFactors HCM Suite
  • BizX Platform

Cause

  • The employee has an invalid manager associated with his or her record. This could be caused by the wrong Manager USERID being entered or due to the manager's record being INACTIVE (terminated or on leave employee).

Resolution

  • Use the check tool to check the User Hierarchy is correct to do this navigate to Check Tool -> User Management-> Hierarchy - See KBA 2472648 Check Tool: How to check your SuccessFactors configuration.
  • Review the employee and manager records in the import file (UDF).
  • Review who is listed as the manager's manager in the import file (UDF).
    • If it is the employee, correct this and reload the file.
    • If the manager is listed as reporting to the correct person, continue looking up the chain at the record of each manager until you discover the erroneous reporting relationship.
  • When you have corrected the record, import the UDF again.

Please NOTE: If you are updating this manually, but normally you have an automated import from your HRIS system, you will need to make sure the HRIS system has the correct information as well. If not, you automated imports can overwritte your fix on the affecting users.

Keywords

Invalid Manager Id , Check tool , Failed to update manager , Import , Export , unable to update , Manager , manager ,  Invalid Manager ID , KBA , sf error messages platform , LOD-SF-PLT-MNG , Manage user issues , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors HCM Suite all versions