SAP Knowledge Base Article - Public

2087543 - Data Imports & Exports: User Import Employee Not Imported Due to Incorrect Date Format - Platform

Symptom

  • Correcting data format issues when importing Employees.
     
     
  • Using Employee Import option through admin tools an import file was selected to add a new employee and imported. An email was generated that shows the 'process' completed successfully, no error was produces, however the user was not created.

Environment

  • BizX Platform

Cause

  • Incorrect date format. MM/DD/YYYY format is required for all date fields.

Resolution

  • If this import file is generated through an SAP or any HRIS system you would also need to make sure you pass the 0's in the file, and that dates are in the format required by SuccessFactors MM/DD/YYYY

 

Additional Information

  • Below is an example of the information contained in the confirmation email. In this example, the 1 record was not imported even though the process itself completed successfully. It is important to review these emails as they provide insightful information indicating whether records have been imported or not. This may help you determine quickly if your data was imported as desired.

Total records: 1 (1 active user(s), 0 inactive user(s)).
Records with changes: 0.
Records without changes: 1.
Users imported/updated: 0; Failed: 0.
Users marked as inactive: 0; Failed: 0; No status change: 0.
Users transferred: 0; Failed: 0.
User Import Process has completed successfully.

Keywords

KBA , sf bizx system/platform , LOD-SF-PLT , Foundational Capabilities & Tools , Problem

Product

SAP SuccessFactors HCM Core all versions