SAP Knowledge Base Article - Public

2086613 - Competencies Are Missing In a Performance Form

Symptom

After launching Performance Forms, competencies are missing.

Note: It is not possible to correct live forms since the competency content become native to the form on launch. The only way to correct these types of issues is by correcting your template and relaunching your forms.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Launch performance forms manually or via automated tools
  2. Performance forms are missing some or all competencies

Cause

  1. Job Profile Builder is enabled, but the JDM to JPB migration has not been completed
  2. Job Description Manager data was modified in Provisioning after JPB migration *Partners and Product Support Only*
  3. A performance form template with hard-coded competencies was copied from another instance
  4. Incorrect competency mapping depending on if Employee Central is enabled
  5. Competencies were deleted
  6. Competencies are inactive
  7. Competencies were not created for English US
  8. Competency language translations have not been created for the user's locale
  9. The performance form template translation has not been created for the user's locale
  10. The job code is not tied to the correct role OR the role is not tied to the expected competencies
  11. The job code wasn't entered for an employee before the performance form was launched
  12. Performance forms have competency filters
  13. The user launching the performance form (job executor) does not have permission to see competencies
  14. (Employee Central Only) The HRIS sync job runs after the Initiate PM Form On Job Change Event for future-dated changes

Resolution

  1. Job Profile Builder is enabled, but the JDM to JPB migration has not been completed
    1. Log into SuccessFactors
    2. Navigate to Admin Center > Tools > Scheduled Job Manager
    3. Select the Job Monitor tab
    4. Locate the Job Type dropdown and search for JDM Old to New Sync:
      • If you do have a result in Scheduled Job Manager, you are on Job Profile Builder. This scenario will not apply.
      • If you do not have a result in Scheduled Job Manager, you are on Job Description Manager but your data has been managed in Job Profile Builder. This will require the migration from JDM to JPB and the steps to proceed are outlined in 276692 - Best Practices on JDM to JPB Migration.
  1. Job Description Manager data was modified in Provisioning after JPB migration *Partners and Product Support Only* 

    • After a customer has been migrated to Job Profile Builder, family and job role data should no longer be maintained in Provisioning. Any changes made from Provisioning aren't synced with data in the system and will cause issues with competencies displaying in performance forms.
    • Changes to family and job role data in Provisioning can be verified in the Check Tool. All Check Tool errors for Job Description Manager must be addressed before the migration. If Job Description Manager errors appear after the migration, family and job data is being modified in Provisioning.
    • All Check Tool errors must be addressed again, and performance forms will need to be relaunched

  2. A performance form template with hard coded competencies was loaded from another instance 

    Each time a new competency is loaded/created in the instance, it will get a unique ID (not to be confused with GUID) specific to that instance. The system assigns these IDs in a sequence, and the sequencing may be different in each instance. If a template is loaded from instance A to instance B, instance B will not be able to identify the competency ID in the template.

    This can be addressed by manually adjusting the competency IDs in the performance form template. As a customer, you do not have access to Provisioning. Please reach out to your Certified Partner if you have one, or look for one using 2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud].
    1. Please provide your Certified Partner with a list of the competency IDs (not GUID) from instance A that should be replaced with the competency IDs from instance B.
    2. They can update the performance form templates with the indicated changes
    3. Once this has been corrected, performance forms will need to be relaunched
  1. Incorrect competency mapping depending on if Employee Central is enabled
    • Performance forms do not support the mapping of competencies to Roles via Job Classification. The competencies need to be mapped via Job Code to Roles in order to show up in the Performance form.
    • If you are using the Job Classification object and have Employee Central enabled, the Job Classification value is synchronized to the User Data File > jobCode column via the HRIS Sync job.
    • Job code of type JOBCODE is from the User Data File JOBCODE field. Job code of type JOBCLASSIFICATION is from the MDF Job Classification object. When mapping job codes, those codes that you see appended with "- FO" are of type JOBCLASSIFICATION. It’s recommended to use JOBCLASSIFICATION if you have Employee Central implemented and JOBCODE if you don’t have an Employee Central implementation in your instance.
    • More information is in Implementing and Managing Job Profile Builder - More About Mapping Job Codes
  1. Competencies were deleted

    • Broken live forms will need to be deleted and relaunched. Historical forms and reports will break since the master competency it was linked to is gone.
    • It is not possible to restore a competency once it has been deleted. Support and Engineering cannot undo or fix the deletion.

  2. Competencies are inactive

    1. Go to Admin Tools > Manage Center of Capabilities
    2. On the left-hand side, select Competencies
    3. Check the boxes next to the competencies you want to change the status of
    4. Select Change Status > Select Active > Change
    5. Relaunch performance forms

  3. Competencies were not created for English US

    If using the auto-population function, all competencies/behaviors need to be created in English US.

    1. Follow the steps in Using Center of Capabilities - Adding Translations for Capabilities Library Entities
    2. Relaunch the performance form

  4. Competency language translations have not been created for the user's locale

    When using multiple languages, it's common for administrators to forget to physically add content for each language that exists. For every language enabled, please ensure content for the language is also translated and entered, and map the new language to the existing competency GUID when using a multi-lingual form. Some clients accidentally load the new language with a GUID that is not linked to the default language (usually English).

    1. Follow the steps in Using Center of Capabilities - Adding Translations for Capabilities Library Entities
    2. Relaunch the performance form

  5. The performance form template translation has not been created for the user's locale

    For example, the instance is configured for en_GB only, but the performance form was set to en_US, so none of the competencies show up.

    1. Follow the steps in Implementing and Managing Performance Management - Localizing Labels
    2. Relaunch the performance form

  6. The job code is not tied to the role OR the role is not tied to the competencies

    The most popular way to pull competencies into a performance form is via job code mapping. When an employee's job code does not match the role set up in Families and Roles, the expected competencies will not pull into the form. It is important the competency data, job codes, families, and roles are all entered and correct before launching a form.

    Note: Job codes are case sensitive and must exactly match in the employee record, families, and roles. If there are any spaces or differences, it will break the mapping and competencies will not populate for that role.

    1. Ensure the correct job code has been added to the employee's record
    2. Navigate to Admin Center > Manage Job Profile Content
    3. Select Content Type > Set Up Families and Roles
    4. Select the Roles tab > Select the role
    5. Confirm the correct Job Code/Job Classification is tied to the role
    6. Confirm the correct competencies are tied to the role
    7. If any corrections are made, relaunch the performance form

  7. The job code wasn't entered for the employee before the performance form was launched

    This is a common scenario for new employees or new roles where an employee is entered into the system and a performance form is automatically launched. If the form is configured to populate competencies according to the job code, the system references the job code the employee has at the time the form is launched. If the employee did not have a job code at the time of form launch, no competencies will be populated. If the employee job code changed after the form launched, the form will continue populating the competencies related to the original job code.

    Please review 2530838 - Initiate PM Form On Job Change Event: How to Launch a New Performance Form Based on a Job Info Change.

  8. Performance forms have competency filters

    A template may have been configured to populate content based on specific libraries or categories. When adding new competencies, if they were not setup correctly to match the filters already built into the templates, it's possible no competencies will show or only some will appear.

    As a customer, you do not have access to Provisioning. Please reach out to your Certified Partner if you have one, or look for one using 2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud].

    1. Ask your Certified Partner to evaluate the template and confirm if any filters are set in this section
      • If there are filters for categories or libraries, ensure the competencies match those coded to the template
      • Determine if the template should be changed to match competency data, or if competency data can be changed to match the existing template
    2. Partners can utilize the following documentation:
    3. Relaunch performance forms

  9. The user launching the performance form (job executor) does not have permission to see competencies

    This can apply to either manually launching a performance form, or having the performance forms launch automatically. The settings within the Competency Object Definition determine whether the permission to see competencies populates within the Role-Based Permissions screen.

    1. Check if the Competency Object definition has Secured=Yes:
      1. Admin Center > Configure Object Definitions
      2. Select Object Definition > Competency
        ''   ''
    2. If the competency object has secured=Yes, grant the job executor permission to access competencies:
      1. Admin Center > Manage Permission Role
      2. Select role of job executor
      3. Select Permission... link
      4. Under User Permissions section, select Miscellaneous Permissions
      5. Grant permission to the Competency section and RoleEntity section
        ''
  10. (Employee Central Only) The HRIS sync job runs after the Initiate PM Form On Job Change Event for future-dated changes

    Performance Management uses the data in the UDF to pull into performance forms. If the HRIS sync job runs after the Initiate PM Form On Job Change Event, the Performance Management module may not have all the information needed to populate the forms. This can be corrected by modifying the timing of the HRIS sync job.

    As a customer, you do not have access to Provisioning. Please reach out to your Certified Partner if you have one, or look for one using 2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud].

    Partners can review Managing Scheduled Jobs - Creating a Scheduled Job Request in Admin Center.

See Also

Keywords

Job code, SF, success factors, PMGM, PM, no competencies in a form, competency, 360, multi-rater, jdm, jpb, map, family, role, sync, missing, section, jobcode, classification, new hire, employee, language, import, library, locale, translation, filter, hard-coded, deleted, custom, core , KBA , LOD-SF-PM-FAM , Competencies Behaviors Families and Roles , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-TIH-JPB-MIG , Migration to Job Profile Builder , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Performance & Goals all versions