Symptom
- Your Performance Management form uses an adjusted rating scale which maps to the overall performance rating score. The calculation on the performance management form is not mapping to the correct value in your adjusted scale value, even though it’s calculated correctly. How can I fix it the form rating calculation?
- We have a adjusted-scale-map that maps scores, but it is not adjusting as we expect for some ratings.
Environment
- Performance Management
Cause
- The attribute ‘<num-decimal-places>’ may need to be increased to handle better decimal precision. For example, is num-decimal-places is set to 1, rounding will only show one decimal place.
Example we have a map
- 3 - 3.33 mapped to 4.
- 3.34 - 4 mapped to 4.5
Anyone that gets a 3.34 will be seen as only getting 3.3 and get a 4 when you expect to get a 4.5
Resolution
Changing decimal precision from <num-decimal-places>1 to <num-decimal-places>2 or greater will enable the system to handle your scores as expected.
For a more detailed explanation of other factors that can impact your ratings please see:
Keywords
KBA , sf rating scales , LOD-SF-PM , Performance Management , How To
Product
SAP SuccessFactors HCM Core all versions