SAP Knowledge Base Article - Public

2078023 - Permissions - New Templates not displaying (RBP) - Performance Management

Symptom

After adding a new Performance Management template, it is not visible in the list of templates in Manage Permission roles.

**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**

Environment

SuccessFactors Performance Management

Reproducing the Issue

1. Go to Manage Permission Roles

2. Select role

3. Select Permissions

Under General User Permissions, the new Performance Management template is not visible.

Cause

  • Often changes to RBP do not apply immediately.

Resolution

  • Admins need to understand that when using Role Based Permissions, the RBP has to refresh so that the new templates appear under the Permission set.
  • In a RBP environment this typically happens after the change to the permission, however, sometimes the changes to RBP are not applied immediately.

Workarounds: The following workaround has worked for some customers.

  • To shorten this delay, disable and re-enable the goal plan or performance review template.
    Wait for about 30 minutes to see the goal plan or performance review template appear in your role based permissions.

For Partners/Support:

  • If you have access to Provisioning, you may trigger a manual refresh by going to Company Settings and using "Refresh RBP Permission Configuration":

RBP refresh

Note:

The best advice is to wait for the automatic refresh, as opening an incident may take longer to process than waiting for the automatic refresh.

Manually refreshing role based permissions can have performance impacts, therefore, it is not recommended that you refresh multiple times a day.

Additionally:

If you have refreshed RBP (or waited some time) and you still do not see the template, open another browser and check if you can now view it in RBP. Reason: the inner scrollbar (in the permission role) is sometimes inhibited from showing when using Internet Explorer. To remedy this: update to the newest version of Internet Explorer 11. Click here to see how.

Keywords

RBP, Performance Templates, not visible, permissions, new template, refresh, manage permission roles , KBA , sf rbp - role based permissions , sf performance manage permissions , LOD-SF-PM , Performance Management , LOD-SF-GM , SAP SF Goal Management , Problem

Product

SAP SuccessFactors HCM Core all versions