SAP Knowledge Base Article - Public

2075395 - Reports run by an Admin are getting stuck in "Waiting in Queue"

Symptom

Reports run by an Admin are getting stuck in "Waiting in Queue" status and are never generated.

Environment

SuccessFactors Learning Management System (LMS)

Cause

The following workflows are not added to the Admin role, both workflows can be found under "System Administration":

  • Edit all back ground job
  • View all background job

Resolution

Add both workflows to the Admin role. If they are not added to the role, having the permissions to run the report, they will remain stuck in the queue.

To add mentioned workflows, you can follow the steps below:

  1. Go to System Admin->Security->Role Management;
  2. Find the desired Role and Edit it;
  3. Go to Workflows;
  4. Click in "add one or more from list";
  5. Expand "System Administration";
  6. Find both roles (Edit all back ground job and View all background job) and check the "Add" checkbox;
  7. Click in the "Add" button.

If the admin already has the Edit and View All background job workflows, but the reports are still getting stuck or if reports from all admins are getting stuck, please create an incident. We will work with our Operations Team to solve it.

Keywords

Stuck in Queue, Not Generated, Can't Run Report, cannot, Not able to run report , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , SuccessFactors Learning , LOD-SF-LMS-BCJ , LMS Background Jobs , Problem

Product

SAP SuccessFactors Learning all versions