SAP Knowledge Base Article - Public

1927209 - BusinessViews and LOV's do not work after being migrated using the Upgrade Management Tool (UMT)

Symptom

When using the Upgrade Management Tool (UMT) to migrate to a SAP BusinessObjects Business Intelligence platform 4.0 or SAP BusinessObjects Business Intelligence platform 4.1 system, BusinessViews and LOVs may no longer work after being migrated.  If the BusinessViews are migrated using the BusinessView Manager program import and export function - they work, but any reports based off of them lose their connection to the BusinessView.

In addition, Crystal Reports based off of the BusinessViews will not return any data.

Environment

  • SAP BusinessObjects Business Intelligence platform 4.0
  • SAP BusinessObjects Business Intelligence platform 4.1

Reproducing the Issue

  1. Migrate a Crystal Report that uses a BusinessView using the UMT tool
  2. After migrating, trying to view the report returns no data

Cause

This issue can occur if the BusinessView Manager tool is not installed on the destination server.

Resolution

To resolve this issue, install the BusinessView Manager on the destination server.  The BusinessView Manager tool comes with the client tools.  It is not necessary to install all the client tools - just the BusinessView Manager.

Keywords

blank BV LOV UMT Migrate Migration Failed no data failure import export XML , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

Crystal Reports 2008 V1