SAP Knowledge Base Article - Public

1922127 - Missing Facebook Posts and Comments From a Customer on a Facebook wall

Symptom

 Facebook comments and posts are visible on the Facebook wall but not in the queue or agent workspace.

Reproducing the Issue

  1. Go to the Customer Service work center.
  2. Select the Queue view.

Facebook comments and posts are visible on the Facebook wall but not in the queue or agent workspace.

Cause

The missing posts and comments may be due to the privacy settings of the customer on Facebook.

Facebook allows every user to define the security (visibility) of posts and comments that are published on Facebook. If end users decide to enable "extreme privacy settings", i. e. turn off the platform and therefore block access to all 3rd party apps and integration, their comments and posts cannot be imported into Cloud for Customer. A customer may report this as an issue with the product, since these comments and posts are visible on the Facebook wall but not in the Queue or agent workspace.   

Resolution

This is in fact the expected behavior, as Facebook blocks these comments and posts from being retrieved via the API which Cloud for Customer uses to import Facebook wall content.

There is no timeline as to when this limitation will be resolved since this is how Facebook defines how partners can use their APIs.

Keywords

KBA , SRD-HR-TLM , Time and Labour Management , Product Enhancement

Product

SAP C4C CORE all versions ; SAP Cloud for Customer all versions