SAP Knowledge Base Article - Public

1892221 - "Set to Null" Checkbox missing for the parameter in Crystal Reports

Symptom

  • Set to Null checkbox is missing for some parameters in Crystal Reports
  • For same parameter the checkbox is available in a different report.

Environment

  • Crystal Reports 2008
  • SAP Crystal Reports 2011

Reproducing the Issue

  1. Create a report using a Stored Procedure as a datasource in Crystal Reports.
  2. This Stored procedure should have more than one parameter defined in it.
  3. Edit one of the parameter on report level and make it dynamic using the existing list of value(lov) from the Business View Manager
  4. Now when one would refresh the report the checkbox goes missing.
  5. Now edit the parameter once again and select a different list of value.
  6. Refresh the report and the checkbox is available.

Cause

"Set to null" checkbox appears only for those parameters which are created in a Stored Procedure. For rest of the datasource parameters its not available, however with few exceptions.
When the first time the parameter is edited its pointed to a non Stored Procedure datasource lov and so the set to null checkbox goes missing.
Second time when its edited its pointed to a LOV whose datasource for the Data Foundation in Business View Manager is a Stored Procedure.

Resolution

Do not change the Stored Procedure parameter to point to a different  LOV other than a Stored Procedure.

Keywords

prompt, lov, checkbox, set to null, database, bvm , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem

Product

Crystal Reports 2008 V1 ; SAP Crystal Reports 2011