1866456 - When the Service Agent trying to maintain or change his/her E- mail, the E-mail Id field is greyed out and you can't edit it.

SAP Knowledge Base Article - Public

1866456 - When the Service Agent trying to maintain or change his/her E- mail, the E-mail Id field is greyed out and you can't edit it.

Symptom

When the Service Agent trying to maintain or change his/her E- mail, the E-mail Id field is greyed out and you can't edit it.

 

 

Reproducing the Issue

  1. Go to Work Center Home.
  2. Choose view Self-Services overview.
  3. Choose Edit my Contact data under Company Address Book.
  4. E-mail field is not editable greyed out.

Cause

The service agent E-mail IDs (In-House email) can be maintained only by administrators via Service Agents view from the following locations:

•Business Partner Data work center

•Supplier Base work center

 The service agent or an employee cannot maintain or change his/her E-mail id from Edit my Contact data under Company Address Book from the self-service overview, since the email has been made read only due to security reasons. If the service agent wants to maintain or change his/her e-mail ID he needs to contact his/her administrator.

Resolution

The workplace email address can only be maintained by administrator as follows.

 (1)    From Business Partner Data work center.

  1. Go to Work center Business Partner Data.
  2. Choose view Service Agents.
  3. Choose the desired service agent.
  4. Choose General under Edit button.
  5. Click on link Copy Address under In-House Address.
  6. Allocate the desired address to the service agent once you allocate the In-House Address the field E-mail will be enabled under In-House Communication.
  7. Enter the In-House Communication details, such as E-mail etc.
  8. Review the details and click Save to save the details.

 (2) Form Supplier Base work center.

  1. Go to Work Center Supplier Base.
  2. Choose the View Service Agent.
  3. Choose the desired service agent.
  4. Choose General under Edit button.
  5. Click on link Copy Address under In-House Address.
  6. Allocate the desired address to the service agent once you allocate the In-House Address the field E-mail will be enabled under In-House Communication
  7. Enter the In-House Communication details, such as E-mail etc.
  8. Review the details and click Save to save the details.

The new workplace contact details are saved to the system which will be replicated in the Home Self Service work center.

Keywords

KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To

Product

SAP BUSINESS BYDESIGN 1708