1724729 - Crystal Reports UFL created in Visual Studio .NET is not working after deploying

SAP Knowledge Base Articles - public

1724729 - Crystal Reports UFL created in Visual Studio .NET is not working after deploying


After following the instructions in KBA 1266912 to deploy a Visual Studio .NET Crystal Reports UFL one of the following errors occurs:

  • Error in formula the ) is missing.
  • System.Runtime.InteropServices.COMException (0x80041019): The ) is missing.
  • Formula functions defined in the UFL do not appear in the Crystal Reports designer.
  • Error in file C:\DOCUME~1\temp<guid>.rpt: The request could not be submitted for background processing.


  • Windows 7 x64
  • Crystal Reports for Visual Studio 2010

Reproducing the Issue

  1. Follow steps in KBA 1266912 to register the UFL.
  2. Try and run a report with the registered UFL in a custom application or through enterprise.
  3. Try and use the UFL in the Crystal Reports designer.


If a Crystal Reports UFLs created in Visual Studio .NET has a dependency that needs to be loaded from their own specific directory, those dependencies will not be found and loaded by Crystal Reports.


  1. Place UFL's and its dependencies into the same directory.
  2. GAC the dll as follows:
    a) Copy the UFL dll into The correct bin directory. For Crystal Reports 2008, this is C:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86
    b) At the .NET command prompt type; gacutil -i "C:\<path to your UFL>"
    This should result in the message; "Assembly successfully added to the cache."
  3. Run REGASM from the command prompt:
    Type regasm codebase "C:\<path to your UFL>"

See Also

1266912 - How to deploy Crystal Reports UFL created in Visual Studio .NET


User, Function, Library, custom, dll, formula , KBA , BI-DEV-NET , BI Software Development Kits (SDKs) - .NET or Other , BI-BIP-PUB , Publishing and scheduling in InfoView/BI launch pad , Problem


SAP Crystal Reports, developer version for Microsoft Visual Studio