SAP Knowledge Base Article - Public

1632327 - Access Restriction for Employees Does not Work in Customer Accounts

Symptom

Access Restriction for employees does not work in customer accounts.

Reproducing the Issue

Follow the steps below to restrict an employee for a particular sales unit:

  1. Go to the Application and User Management work center.
  2. Go to the User and Access Management view.
  3. Go to the Business Users subview.
  4. Show All Business users and Find XYZ (XYZ represents the identification of the user).
  5. Select the user XYZ.
  6. Choose Edit button and select Access Rights.
  7. Select the Access Restriction tab.
  8. Select the work center view ID BPM_Accounts
  9. Restrict the user for the sales unit ABC for accounts (ABC represents the identification of the sales unit).

Follow the steps below to reproduce the issue:

  1. Login to the SAP Business ByDesign system with user XYZ.
  2. Go to the Account Management work center.
  3. Go to the Accounts view.
  4. Show All Accounts and choose Go button.
  5. All accounts available in the system are shown here without considering the restriction for user XYZ.

 

Cause

In current release of the SAP Business ByDesign system the display of accounts does not follow the restriction rule for the user and all accounts are shown.
This logic for the access restriction based on the employee sales unit would be implemented in one of the future release.

Resolution

This is the expected behavior of SAP Business ByDesign.

Keywords

KBA , AP-BP-BPT , Business Partner Template , How To

Product

SAP BUSINESS BYDESIGN 1611 ; SAP BUSINESS BYDESIGN 1705 ; SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1302 ; SAP Business ByDesign 1305 ; SAP Business ByDesign 1511 ; SAP Business ByDesign 1608 ; SAP Business ByDesign 1702 ; SAP Business ByDesign 1711 ; SAP Business ByDesign feature pack 2.6 ; SAP Business ByDesign feature pack 3.0 ; SAP Business ByDesign feature pack 3.5 ; SAP Business ByDesign feature pack 4.0