1610748 - Error: 'You are connecting to BW server version < 702, please install BEx3.5 to use SAP Toolbar functionality.' when trying to logon to SAP BW from Crystal Reports

SAP Knowledge Base Article - Public

1610748 - Error: 'You are connecting to BW server version < 702, please install BEx3.5 to use SAP Toolbar functionality.' when trying to logon to SAP BW from Crystal Reports

Symptom

  • Error: "You are connecting to BW server version < 702, please install BEx3.5 to use SAP Toolbar functionality."      
  • In Crystal Reports, when attempting to create, open or save a report using the SAP menu, it fails with the error:
           
         'COM exception caught in CextToolBar::GetRemoteFileCookie().
          HR = 0x8004005 COM exception caught in CextToolBar::InitOpenSaveDialog(). HR = 0x8004005
          You are connecting to BW server version < 702, please install BEx3.5 to use SAP Toolbar functionality.'

Environment

  • SAP Crystal Reports 2008
  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
       
  • SAP Business Warehouse 7.00  ( SAP BW )
  • SAP Business Warehouse 7.01  ( SAP BW )

Reproducing the Issue

  1. In Crystal Reports, under the menu "SAP", select "Create New Report from a Query..."
  2. Log into the SAP BW system.
  3. It will then displays the message: "You are connecting to BW server version < 702, please install BEx3.5 to use SAP Toolbar functionality"   

Cause

  • As the message states, Crystal Reports requires Business Explorer 3.5 ( BEx 3.5 ) to be installed on the same computer to be able to connect to an SAP BW System when connecting to an SAP BW 7.01 and below.
           
  • In the past, the solution was to install the Business Explorer 3.5 tools, but BEx 3.5 is no longer part of the SAP GUI installation, therefore the product was enhanced to be able to connect to SAP BW System 7.01 and below, without the requirement of having to install BEx 3.5.  ( ADAPT01727213 )

Resolution

  • To be able to connect to an SAP BW System version 7.01 and below, using the SAP menu in Crystal Reports designer:
       
    1. Ensure your version of SAP BW System is equal or higher to the following version:
          
      • SAP BW 7.00, SP31   ( Only supported for Crystal Reports 2008 and 2011 )
      • SAP BW 7.01, SP16  
           
          
    2. Apply the following product update:
             
      • Crystal Reports 2008
        • Service Pack 6 - Fix Pack 6.5
        • Service Pack 7 - Fix Pack 7.2 and above
                      
      • Crystal Reports 2011
        • Support Pack 10, or above
                 
      • Crystal Reports 2013
        • Support Pack 05, or above

Keywords

CR, SAP BW 7.01 and Crystal Reports , KBA , BI-RA-CR , Crystal Reports designer or BusinessViews Manager , Problem

Product

SAP Crystal Reports 2011 ; SAP Crystal Reports 2013